0
0
Subtotal: R0.00
No products in the cart.

TP Link JetStream 28-Port Gigabit Smart

R5243.00

ALL PRICES INCLUDE VAT
Please note: pricing visible is already subject to a 3% discount applicable only to EFT payments.. DISCOUNT LAPSES WHEN PAYING ONLINE
ALL ORDERS WITH PAYMENTS RECEIVED BEFORE 10AM WILL BE DIPATCHED SAME DAY
OVERNIGHT DELIVERIES APPLY ONLY TO MAJOR CITY CENTERS
PLEASE NOTE IMAGES ARE FOR ILLUSTRATION PURPOSE ONLY
AND ACTUAL PRODUCT MAY DIFFER FROM PICTURES
SKU TL-SG2428P Categories , Brand:

NATIONWIDE SHIPPING

We have people placed to serve you all over the country.

ESTIMATED DELIVERY

Delivery is usually between 2 - 3 working days
for Major centers, Outlying areas can take longer Standard delivery fee of R 130.00 DUE TO RECENT INCREASE
All items over 25KG carry a delivery surge charge
Total shipping cost R350.00

HASSLE FREE RETURNS

If you experience any fault products, be assured that the product will be REFUNDED in full.

SHARE:

Description

TP Link JetStream 28-Port Gigabit Smart Switch with 24-Port PoE+, Retail Box, 1 year Limited Warranty
 
Product Overview
Power and manage your network with the TP-Link JetStream 28-Port Gigabit Smart Switch.This versatile switch offers 24 PoE+ ports, delivering power and data to devices like IP cameras and VoIP phones. Benefit from advanced features like centralized cloud management, robust security, and quality of service for optimized network performance. 
 
Specifications
•Product code: TL-SG2428P
•Description: TP-Link JetStream 28-Port Gigabit Smart Switch with 24-Port PoE+
•24× 10/100/1000 Mbps RJ45 Ports (Auto Negotiation/Auto MDI/MDIX)
•4× Gigabit SFP Slots
•Standard: 802.3at/af compliant
•Dimensions ( W x D x H ) 17.3 × 8.7 × 1.73 in (440 × 220 × 44 mm)
•Mounting Rack Mountable
•Max Power Consumption
•32.1 W (110 V/ 60 Hz with no PD connected)
•308.6 W (110 V/ 60 Hz with 250 W PD connected)
•Switching Capacity 56 Gbps
•Bandwidth/Backplane 56 Gbps
•Packet Forwarding Rate 41.7 Mpps
•MAC Address Table 8K
•Packet Buffer Memory 4.1 Mbit
•Jumbo Frame 9KB
•Support 802.1p CoS/DSCP priority
•Support 8 priority queues
•Queue scheduling: SP, WRR, SP+WRR
•Port/Flow- based Rate Limiting
•LLDP, LLDP-MED
•Advanced Features
•Automatic Device Discovery
•Batch Configuration
•Batch Firmware Upgrading
•Intelligent Network Monitoring
•Abnormal Event Warnings
•Unified Configuration
•Reboot Schedule
•Supports up to 4K VLANs simultaneously (out of 4K VLAN IDs)
•DHCP Snooping
•IP-MAC-Port Binding
•IPv6-MAC-Port Binding
•ARP Inspection
•Radius Accounting Client MIB (RFC2620)
•Radius Authentication Client MIB (RFC2618)
•Remote Ping, Traceroute MIB (RFC2925)
•Support TP-Link private MIBs
•RMON MIB(RFC1757, rmon 1,2,3,9)
•Centralized Management
•Omada Cloud-Based Controller
•Omada Hardware Controller (OC300)
•Omada Hardware Controller (OC200)
•Firmware Upgrade: TFTP & Web
•System Diagnose: VCT
•SYSLOG & Public MIBS
•Dual Image

Additional information

Weight3.95 kg
Dimensions53 × 33.5 × 10 cm

Reviews

There are no reviews yet.

Only logged in customers who have purchased this product may leave a review.

RELATED PRODUCTS

Satisfaction Guaranteed

Jason@computech-solutions.co.za

Need Help, Talk To Us

info@computech-solutions.co.za

Delivery Nationwide

dispatch@computech-solutions.co.za